G and AdBlue

14 replies [Last post]
Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members

I'll start this thread - there have been a few about AdBlue over the years.

I have a G350 with the OM642 V6 3Litre engine, and AdBlue.  First time with AdBlue and asides from the hassle of occasionally having to add 10Litres at a small cost of £15 ish, it seems a good idea (inject urea into the exhaust system to convert most of the NOx to N2 and O2 again - less smoke, less EGR needed and enables the G to reach Euro6 levels of efficiency - needed for some city driving, increasingly.  

But AdBlue means more sensors and in an electronic G its always the electronics that get you, because unless you carry around a STAR system there is not much you can do to bypass errors that crop up.  So compared to my mechanical 460, this 463 with AdBlue is already throwing up some occasional dashboard messages!

So the AdBlue message now is that it thinks I need AdBlue, but when adding it, I got to 7Litres and it overflowed all down the side of the G.  Not good - have to wash that stuff off.   Note the theory is that AdBlue is added by the garage at services, but how they know how much to add is a mystery as there is no level indicator, until it spills out!

Then you get the follow up message that without AdBlue topup, you will not be able to start the car in 800miles.   But then the message goes away (zero messages in the COMAND Settings view), only to come back again when you restart, and the timer starts again at 800miles.  Once it said 2400 miles!

The problem came on a long trip, cruising at 80mph+ if that adds any insight.  I am thinking that at those speeds the AdBlue delivery systems is working hard ?

So it looks like a MB visit to me, to check/replace a sensor, or possible the AdBlue delivery pump/system.  

Anyone know anything to try to isolate the actual issue?  Checking something in the COMAND Engineering view for example?

Or got diagrams of the G350 Adblue components? 

bigblock
bigblock's picture
Offline
Joined: 27.05.2009
Location: HIGHLANDS
GWOA Groups: Committee, Members
Re: G and AdBlue

John

My experience with a GLE, Evoque and Ford Ranger using AdBlue is that it can sometimes take a few driving cycles before the system resets correctly and the warnings stop appearing. On the GLE I found that if I turned the ignition on for 30 seconds and then off two or three times after I had refilled the AdBlue it would solve the problem.

 

Pistonhead
Pistonhead's picture
Offline
Joined: 17.12.2006
Location: Loughborough
GWOA Groups: Committee, Members
Re: G and AdBlue

I don't think a disconnection is likely to be an easy fix as the computer is invloved. I have no doubt that it would have some sensor parameteres to look for and anything out of the range would flag up an engine stop light. That is unless if some has on the after market a reprogrammed ECU values.

There is another point not mentioned above, if the vehicle's Ad Blue reservoir is low the stop light will come on initially upto a point if you push it  the engine refuses to start untill the reservoir is replenished and the whole sytem has to be reset using Star or other generic kit would do it too. I have a feeling that low fuel could affect the reset as the DPF is designed to complete a self regeneration with at least that much fuel in in it to complete the cylce - but not 100% certain of that point.

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: G and AdBlue

Thanks Rakesh.

The AdBlue never completely ran out.  The first time it was re-filled after just a few dozen miles and the alarm went away as expected.

The second time. much earlier than expected and whilst cruising at speed, the AdBlue low alarm came on, and after about 150miles (should have 800miles range at least) I topped up with 10L to find that it overflowed at 7L.  The Check Engine light is on and it re-warns every time you start the car, after about 2-5 minutes.   Then after a couple more days, the warning stopped appearing one time, but the Check Engine light remained?

I played today with OBD Plus, an App with an OBDII reader - not recommended - fairly rubbish, and it reported 4 faults. (P43AA, P43A8 twice) But it seems to find a fault each time you run it anyway (I got U4003 and P1303 once). 

I tried clearing the faults, and after multiple attempts 2 of 4 cleared and then, when I next started the car (just now) there is no more Engine light and no more AdBlue warning.  Its gone away.

It will be Serviced on Monday, and will take a look with STAR at the history.

Maybe it was complaining/confused about being over-full.

Pistonhead
Pistonhead's picture
Offline
Joined: 17.12.2006
Location: Loughborough
GWOA Groups: Committee, Members
Re: G and AdBlue

The fault codes you have showing are fuel and, or misfire in No:3 cylinder and the 'U' indicates an emissions fault relating to low AdBlue. This understandable but the misfire should not be AdBlue related it could be now and then you do actually have a misfire.

When were your spark plugs last renewed? Do Check on that history, if you have done the miles change them. Failing to change the spark plugs when due pust additional stress on the coil and eventually this burns out. This is the most common cause of failure for coils on plugs.

Theo
Theo's picture
Offline
Joined: 29.01.2010
Location: Guildford
GWOA Groups: Members
Re: G and AdBlue

Diesel engines have spark plugs?

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: G and AdBlue

Update:

MB Indie (Griffiths in Reading, very good) checked it over.  They had similar before with BlueTec (ML).  They updated the out of date ECU software.  Apparently, this modifies how 'tolerant' the checks are before throwing the exception.  Its likely not measuring the level of AdBlue, but the NOX sensors in the exhaust.... if they decide that not enough NOX is being neutralised, it throws the alarm up.  You can reset it (with OBDII) and it goes away til the next instance.  It explains why I have seen it mostly cruising at speed - more volume of NOX and sensors more likely to decide its too much.

So the new sw should stop it popping up.

There are also new (gen 2) NOX sensors available, but they are not cheap (£300 each, x2) and mine are not showing any faults... they are just more sensitive in v1.

All good.

 

 

 

Pistonhead
Pistonhead's picture
Offline
Joined: 17.12.2006
Location: Loughborough
GWOA Groups: Committee, Members
Re: G and AdBlue

Theo wrote:

Diesel engines have spark plugs?

Sorry, I did not check when making my comment - and you are correct  Diesels don't have spark plugs. Could be Injector or Injector wiring issue,

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: G and AdBlue

Pistonhead wrote:

Theo wrote:

Diesel engines have spark plugs?

Sorry, I did not check when making my comment - and you are correct  Diesels don't have spark plugs. Could be Injector or Injector wiring issue,

I've had injector cleaner added in this service.  The P1303 error only appeared once.  Not concerned with this.

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: G and AdBlue

Refreshing this thread.

Still getting the AdBlue warnings occasionally.  It turns the amber engine light on but no other effect.

I think the errors are the same (I will add here) and suspect the NOX sensors are still telling the ECU something is wrong.  When you OBDII reset the ECU errors, it takes several restarts to remove the engine light, and then it will pop up again after a few days.

The trouble is, its difficult now to know when the AdBlue genuinely needs topping up.  There seems to be no difference in the COMAND message.

So, is there another way to tell the status of the AdBlue tank?  Via Engineering mode in COMAND? or with a dipstick?

Also - anyone know of filling stations that have adblue on-tap?  I'll do a search.

 

 

JASONGDS
JASONGDS's picture
Offline
Joined: 15.07.2011
Location: High Peak
GWOA Groups: Members
Re: G and AdBlue

Must be  a fairly generous reserve? Why not top up to max, then top up after 1000 miles, see how many litres used? Though of course if it runs out will refuse to start, but 1k shouldn't drain it

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: G and AdBlue

Topping up with a carton or AdBlue is a pain.  Last time I did it, when it was still half full as it turns out, it spilled out everywhere from the dispenser when full.  And that stuff is corrosive so you have to wipe it down well.  Plus you then have half a carton of adblue to cart around or store.

Hence I am looking for AdBlue pumps which will dispense what you need to top up, and auto-stop.  I've just never seen them in a filling station so far.  Search online with: "adblue pumps near me" and you get loads of responses, but turns out they are mostly fake advertising and they just sell the 10L cartons.

Engine light is off at the moment and I am using OBDII to try to see what the NOX sensors are pumping out.  So far, it seems erratic (which might be the issue).

JASONGDS
JASONGDS's picture
Offline
Joined: 15.07.2011
Location: High Peak
GWOA Groups: Members
Re: G and AdBlue

On  my dark side land cruiser,  ( sorry) that has Ad blue, Toyota sell 1 litre bottles that you have to push down when top of bottle is screwed  on to the ad blue tank. So making a mess is much harder, still got to work out if one can refill the bottle , assuming the 5 litre container comes with no fancy top?

Probably Germany has it at the pumps.

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: G and AdBlue

There is an AdBlue App to local AdBlue (including where it is pumped).

Disappointingly, it seems there are only 6 pumps in the whole of the UK !  Must be more than that - probably out of date app, but I have yet to see one.

Anyway - I was monitorig the OBD sensor outputs for NOX_Post_SCR.  It shows '2000' ppm NOX while the engine/exhaust warms up - I assume no adblue is added in this phase.  Then at temperature the sensor reports -100 to -96.0 range.  Not what I expected.  If this was a 'percentage' of NOX removal, that would be impressive, but I doubt that very much.

While monitoring, the AdBlue CEL came on again and there was no discernable change in the NOXPostSCR reading.

I am trying to see if a sensor is flakey/worn out, because don't want to replace and find out it is a gummed up delivery pipe instead.

Nothing much to see in the Engineering mode of COMAND either.  I'd really like to know the amount of AdBlue in the tank also if anyone knows how to get that.

bigblock
bigblock's picture
Offline
Joined: 27.05.2009
Location: HIGHLANDS
GWOA Groups: Committee, Members
Re: G and AdBlue

I have seen a few AdBlue pumps at the HGV sections of filling stations but I imagine that they have a standard size nozzle for filling large tanks and would not fit the small tanks fitted to normal passenger vehicles.

I have several vehicles running AdBlue and got fed up constantly topping them up from the small containers so I purchased a 200litre drum with a dispensing pump which makes the whole process much easier. I use the same system for engine oil and I think I might do the same for screenwash.