W463 1991 Oil Gauge help needed

3 replies [Last post]
pearmund
pearmund's picture
Offline
Joined: 24.07.2009
Location: Buckinghamshire
GWOA Groups: Members

Hi, my oil gauge on my 1991 W463 G300 has stopped working. This has happened over time, with the oil pressure looking like its getting lower, and lower whilst it's not. I've replaced the sender, but this hasn't fixed the issue. I'm assuming the oils gauge in the cluster may have gone. Does anyone have any advice on what else may have caused the issue or if the gauge has gone, does anyone know where i can get one from. My personal email is pearmund@gmail.com. Thanks 

 

 

Login or register to view attached files
GWOA Admin
GWOA Admin's picture
Offline
Joined: 11.09.2010
Location: Oxford
GWOA Groups: Committee, Members
Re: W463 1991 Oil Gauge help needed

And yet no oil light on?

Suggests the gauge really then.  There should be a separate gauge behind the face, separate from the speedo unit.  A second hand one would do it, but worth checking for a new one also if you go to the trouble of fitting it there.

Check here for removal, last page: http://gwoa.co.uk/sites/default/files/download_pdf/repair-463/g-repair-manuals-463-headlampsr.pdf    It looks a little unsophisticated!

Also here: http://gwoa.co.uk/node/1563  

JASONGDS
JASONGDS's picture
Offline
Joined: 15.07.2011
Location: High Peak
GWOA Groups: Members
Re: W463 1991 Oil Gauge help needed

Is the sender wiring ok? 

Jdring
Jdring's picture
Offline
Joined: 12.04.2004
Location: South of Oxford, UK. 'dingaling' on the Register
GWOA Groups: Members
Re: W463 1991 Oil Gauge help needed

Wouldn't the same wiring trigger the low oil light?  Assuming the oil light comes one with the ignition and goes out when the engine is running. The current on the wire should move the needle on the gauge, and the lower the current the lower the gauge.  I'm thinking pull the cluster backwards and out and try low current on the back of the gauge.   But I am not any expert in this.